<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="http://gmpg.org/xfn/11">
	<title>Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled</title>

<!-- This site is optimized with the Yoast SEO plugin v11.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Manchu Vishnu starrer Mosagallu is in the last leg of shooting and the film is planned to be released in summer. Bollywood star Suniel Shetty plays a powerful cop in the film and his first look is out now."/>
<link rel="canonical" href="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled" />
<meta property="og:description" content="Manchu Vishnu starrer Mosagallu is in the last leg of shooting and the film is planned to be released in summer. Bollywood star Suniel Shetty plays a powerful cop in the film and his first look is out now." />
<meta property="og:url" content="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/" />
<meta property="og:site_name" content="Navyamedia" />
<meta property="article:tag" content="Mosagallu" />
<meta property="article:section" content="Hindi" />
<meta property="article:published_time" content="2020-02-29T11:37:25+00:00" />
<meta property="og:image" content="https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg" />
<meta property="og:image:secure_url" content="https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg" />
<meta property="og:image:width" content="501" />
<meta property="og:image:height" content="336" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Manchu Vishnu starrer Mosagallu is in the last leg of shooting and the film is planned to be released in summer. Bollywood star Suniel Shetty plays a powerful cop in the film and his first look is out now." />
<meta name="twitter:title" content="Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled" />
<meta name="twitter:image" content="https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://navyamedia.com/#organization","name":"","url":"https://navyamedia.com/","sameAs":[]},{"@type":"WebSite","@id":"https://navyamedia.com/#website","url":"https://navyamedia.com/","name":"Navyamedia","publisher":{"@id":"https://navyamedia.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://navyamedia.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#webpage","url":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/","inLanguage":"en-US","name":"Suniel Shetty\u2019s Dynamic First look in \u2018Mosagallu\u2019 Unveiled","isPartOf":{"@id":"https://navyamedia.com/#website"},"image":{"@type":"ImageObject","@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#primaryimage","url":"https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg","width":501,"height":336,"caption":"Suniel Shetty\u2019s Dynamic First look in \u2018Mosagallu\u2019 Unveiled"},"primaryImageOfPage":{"@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#primaryimage"},"datePublished":"2020-02-29T11:37:25+00:00","dateModified":"2020-02-29T11:37:25+00:00","description":"Manchu Vishnu starrer Mosagallu is in the last leg of shooting and the film is planned to be released in summer. Bollywood star Suniel Shetty plays a powerful cop in the film and his first look is out now.","breadcrumb":{"@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#breadcrumb"}},{"@type":"BreadcrumbList","@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://navyamedia.com/","url":"https://navyamedia.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/","url":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/","name":"Suniel Shetty\u2019s Dynamic First look in \u2018Mosagallu\u2019 Unveiled"}}]},{"@type":"Article","@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#article","isPartOf":{"@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#webpage"},"author":{"@id":"https://navyamedia.com/author/admin/#author"},"headline":"Suniel Shetty\u2019s Dynamic First look in \u2018Mosagallu\u2019 Unveiled","datePublished":"2020-02-29T11:37:25+00:00","dateModified":"2020-02-29T11:37:25+00:00","commentCount":0,"mainEntityOfPage":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#webpage","publisher":{"@id":"https://navyamedia.com/#organization"},"image":{"@id":"https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#primaryimage"},"keywords":"Mosagallu","articleSection":"Hindi,Telugu Cinema News"},{"@type":["Person"],"@id":"https://navyamedia.com/author/admin/#author","name":"admin","image":{"@type":"ImageObject","@id":"https://navyamedia.com/#authorlogo","url":"https://secure.gravatar.com/avatar/ecf37558ae43fd25a2b803fbb0ac5b28?s=96&d=mm&r=g","caption":"admin"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Navyamedia &raquo; Feed" href="https://navyamedia.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navyamedia &raquo; Comments Feed" href="https://navyamedia.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Navyamedia &raquo; Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled Comments Feed" href="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/navyamedia.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://navyamedia.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://navyamedia.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='pencisc-css'  href='https://navyamedia.com/wp-content/plugins/penci-framework/assets/css/single-shortcode.css?ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='penci-font-awesome-css'  href='https://navyamedia.com/wp-content/themes/pennews/css/font-awesome.min.css?ver=4.5.2' type='text/css' media='all' />
<link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=Roboto%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMukta+Vaani%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7COswald%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CTeko%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CSue+Ellen+Francisco%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='penci-portfolio-css'  href='https://navyamedia.com/wp-content/themes/pennews/css/portfolio.css?ver=6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='penci-recipe-css'  href='https://navyamedia.com/wp-content/themes/pennews/css/recipe.css?ver=6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='penci-review-css'  href='https://navyamedia.com/wp-content/themes/pennews/css/review.css?ver=6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='penci-style-css'  href='https://navyamedia.com/wp-content/themes/pennews/style.css?ver=6.5.1' type='text/css' media='all' />
<style id='penci-style-inline-css' type='text/css'>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</style>
<script type='text/javascript' src='https://navyamedia.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://navyamedia.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://navyamedia.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://navyamedia.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.2.5" />
<link rel='shortlink' href='https://navyamedia.com/?p=79195' />
<link rel="alternate" type="application/json+oembed" href="https://navyamedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://navyamedia.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;format=xml" />
<script>
var portfolioDataJs = portfolioDataJs || [];
var penciBlocksArray=[];
var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
		<style type="text/css">
																										</style>
				<style type="text/css">
																		.penci-review .penci-review-process span { background-color:#dd9933; }																													</style>
		<!-- <meta name="NextGEN" version="3.2.2" /> -->
<link rel="pingback" href="https://navyamedia.com/xmlrpc.php"><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "organization",
    "@id": "#organization",
    "logo": {
        "@type": "ImageObject",
        "url": "https:\/\/navyamedia.com\/wp-content\/uploads\/2019\/04\/cropped-download.png"
    },
    "url": "https:\/\/navyamedia.com\/",
    "name": "Navyamedia",
    "description": "AP,Telangana Political News | Telugu Cinema News"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WebSite",
    "name": "Navyamedia",
    "alternateName": "AP,Telangana Political News | Telugu Cinema News",
    "url": "https:\/\/navyamedia.com\/"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Sidebar Right",
    "alternateName": "Add widgets here to display them on blog and single",
    "url": "https:\/\/navyamedia.com\/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Sidebar Left",
    "alternateName": "Add widgets here to display them on page",
    "url": "https:\/\/navyamedia.com\/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "WPSideBar",
    "name": "Hamburger Widget Below",
    "alternateName": "Display widgets on below menu on menu hamburger",
    "url": "https:\/\/navyamedia.com\/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled"
}</script><script type="application/ld+json">{
    "@context": "http:\/\/schema.org\/",
    "@type": "BlogPosting",
    "headline": "Suniel Shetty\u2019s Dynamic First look in \u2018Mosagallu\u2019 Unveiled",
    "description": "",
    "datePublished": "2020-02-29",
    "datemodified": "2020-02-29",
    "mainEntityOfPage": "https:\/\/navyamedia.com\/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled\/",
    "image": {
        "@type": "ImageObject",
        "url": "https:\/\/navyamedia.com\/wp-content\/uploads\/2020\/02\/Suniel-Shetty.jpg",
        "width": 501,
        "height": 336
    },
    "publisher": {
        "@type": "Organization",
        "name": "Navyamedia",
        "logo": {
            "@type": "ImageObject",
            "url": "https:\/\/navyamedia.com\/wp-content\/uploads\/2019\/04\/cropped-download.png"
        }
    },
    "author": {
        "@type": "Person",
        "@id": "#person-admin",
        "name": "admin"
    }
}</script><meta property="fb:app_id" content="348280475330978"><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://navyamedia.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><link rel="icon" href="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-1-270x270.png" />
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript>	<style>
		a.custom-button.pencisc-button {
			background: transparent;
			color: #D3347B;
			border: 2px solid #D3347B;
			line-height: 36px;
			padding: 0 20px;
			font-size: 14px;
			font-weight: bold;
		}
		a.custom-button.pencisc-button:hover {
			background: #D3347B;
			color: #fff;
			border: 2px solid #D3347B;
		}
		a.custom-button.pencisc-button.pencisc-small {
			line-height: 28px;
			font-size: 12px;
		}
		a.custom-button.pencisc-button.pencisc-large {
			line-height: 46px;
			font-size: 18px;
		}
	</style>
	
	<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-103234948-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-103234948-1');
</script>
<link rel='stylesheet' id='vc_google_fonts_muktavaani-css'  href='//fonts.googleapis.com/css?family=Mukta+Vaani&#038;ver=5.2.5' type='text/css' media='all' />
</head>

<body class="post-template-default single single-post postid-79195 single-format-standard wp-custom-logo group-blog header-sticky penci_enable_ajaxsearch penci_sticky_content_sidebar sidebar-right penci-single-style-1 wpb-js-composer js-comp-ver-5.5.2 vc_responsive">

<div id="page" class="site">
	<div class="penci-topbar clearfix style-1">
	<div class="penci-topbar_container topbar-width-default">

					<div class="penci-topbar__left">
				<div class="topbar_item topbar_date">
	March 1, 2020</div>
<div class="topbar_item topbar__menu"><ul id="menu-top" class="menu"><li id="menu-item-59335" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59335"><a href="https://navyamedia.com/contact-us/">Contact Us</a></li>
<li id="menu-item-59336" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59336"><a href="https://navyamedia.com/advertise-with-us/">Advertise With us</a></li>
<li id="menu-item-59337" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59337"><a href="https://navyamedia.com/disclaimer/">Disclaimer</a></li>
<li id="menu-item-59338" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-59338"><a href="https://navyamedia.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-59494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59494"><a href="http://telugu.navyamedia.com/">Telugu Website</a></li>
</ul></div>			</div>
			<div class="penci-topbar__right">
				<div class="topbar_item topbar__social-media">
	<a class="social-media-item socail_media__facebook" target="_blank" href="https://www.facebook.com/navyamedia/" title="Facebook" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target="_blank" href="https://twitter.com/Navyamedia" title="Twitter" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a></div>


			</div>
			</div>
</div>
<div class="site-header-wrapper"><div class="header__top header--s2">
	<div class="penci-container-fluid header-top__container">
		
<div class="site-branding">
	
		<h2><a href="https://navyamedia.com/" class="custom-logo-link" rel="home"><img width="444" height="114" src="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download.png" class="custom-logo" alt="Navyamedia" srcset="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download.png 444w, https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-300x77.png 300w" sizes="(max-width: 444px) 100vw, 444px" /></a></h2>
				</div><!-- .site-branding -->
		
	</div>
</div>
<header id="masthead" class="site-header header--s2" data-height="80" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="penci-container-fluid header-content__container">
		<nav id="site-navigation" class="main-navigation pencimn-slide_down" itemscope itemtype="http://schema.org/SiteNavigationElement">
	<ul id="menu-main-menu" class="menu"><li id="menu-item-88" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88"><a href="https://navyamedia.com/home/" itemprop="url">Home</a></li>
<li id="menu-item-84" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-84"><a href="https://navyamedia.com/category/news/" itemprop="url">news</a>
<ul class="sub-menu">
	<li id="menu-item-85" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-85"><a href="https://navyamedia.com/category/news/politics/" itemprop="url">Political News</a>
	<ul class="sub-menu">
		<li id="menu-item-59498" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59498"><a href="https://navyamedia.com/category/andhra-pradesh-political-news/" itemprop="url">Andhra Pradesh</a></li>
		<li id="menu-item-59504" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59504"><a href="https://navyamedia.com/category/telangana/" itemprop="url">Telangana</a></li>
		<li id="menu-item-59502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59502"><a href="https://navyamedia.com/category/national/" itemprop="url">National</a></li>
		<li id="menu-item-59501" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59501"><a href="https://navyamedia.com/category/international/" itemprop="url">International</a></li>
	</ul>
</li>
	<li id="menu-item-86" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-86"><a href="https://navyamedia.com/category/news/telugu-cinema-news/" itemprop="url">Cinema News</a>
	<ul class="sub-menu">
		<li id="menu-item-59507" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59507"><a href="https://navyamedia.com/category/telugu/" itemprop="url">Telugu</a></li>
		<li id="menu-item-59506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59506"><a href="https://navyamedia.com/category/tamil/" itemprop="url">Tamil</a></li>
		<li id="menu-item-59505" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-59505"><a href="https://navyamedia.com/category/hindi/" itemprop="url">Hindi</a></li>
	</ul>
</li>
	<li id="menu-item-59096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59096"><a href="https://navyamedia.com/category/crime/" itemprop="url">Crime News</a></li>
</ul>
</li>
<li id="menu-item-59497" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59497"><a href="#" itemprop="url">Galleries</a>
<ul class="sub-menu">
	<li id="menu-item-78" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://navyamedia.com/category/artistes-gallery/" itemprop="url">Artist Gallaery</a></li>
	<li id="menu-item-83" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://navyamedia.com/category/movie-gallery/" itemprop="url">Movie Gallery</a></li>
</ul>
</li>
<li id="menu-item-79" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79"><a href="https://navyamedia.com/category/business-news/" itemprop="url">Business News</a></li>
<li id="menu-item-59098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59098"><a href="https://navyamedia.com/category/education-news/" itemprop="url">Educational News</a></li>
<li id="menu-item-59500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59500"><a href="https://navyamedia.com/category/health-news/" itemprop="url">Health News</a></li>
<li id="menu-item-59503" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59503"><a href="https://navyamedia.com/category/technology/" itemprop="url">Technology</a></li>
<li id="menu-item-59508" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59508"><a href="https://navyamedia.com/category/sports/" itemprop="url">Sports News</a></li>
<li id="menu-item-59147" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59147"><a href="http://telugu.navyamedia.com/" itemprop="url">Telugu Website</a></li>
</ul>
</nav><!-- #site-navigation -->
		<div class="header__social-search">
		
			<div class="header__social-media">
			<div class="header__content-social-media">

			<a class="social-media-item socail_media__facebook" target="_blank" href="https://www.facebook.com/navyamedia/" title="Facebook" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target="_blank" href="https://twitter.com/Navyamedia" title="Twitter" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a>						</div>
		</div>
	
</div>

	</div>
</header><!-- #masthead -->
</div><div class="penci-header-mobile" >
	<div class="penci-header-mobile_container">
		<button class="menu-toggle navbar-toggle" aria-expanded="false"><span class="screen-reader-text">Primary Menu</span><i class="fa fa-bars"></i></button>
										<div class="site-branding"> <a href="https://navyamedia.com/" class="custom-logo-link logo_header_mobile"><img src="https://navyamedia.com/wp-content/uploads/2018/08/download.jpg" alt="Navyamedia"/></a></div>
						</div>
</div>	<div id="content" class="site-content">
	<div id="primary" class="content-area">
		<main id="main" class="site-main" >
				<div class="penci-container">
		<div class="penci-container__content penci-con_sb2_sb1">
			<div class="penci-wide-content penci-content-novc penci-sticky-content penci-content-single-inner">
				<div class="theiaStickySidebar">
					<div class="penci-content-post noloaddisqus " data-url="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/" data-id="79195" data-title="">
					<div class="penci_breadcrumbs "><ul itemscope itemtype="http://schema.org/BreadcrumbList"><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><a class="home" href="https://navyamedia.com" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><i class="fa fa-angle-right"></i><a href="https://navyamedia.com/category/hindi/" itemprop="item"><span itemprop="name">Hindi</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem"><i class="fa fa-angle-right"></i><a href="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/" itemprop="item"><span itemprop="name">Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled</span></a><meta itemprop="position" content="3" /></li></ul></div>						<article id="post-79195" class="penci-single-artcontent noloaddisqus post-79195 post type-post status-publish format-standard has-post-thumbnail hentry category-hindi category-telugu-cinema-news tag-mosagallu penci-post-item">

							<header class="entry-header penci-entry-header penci-title-">
								<div class="penci-entry-categories"><span class="penci-cat-links"><a href="https://navyamedia.com/category/hindi/" rel="category tag">Hindi</a> <a href="https://navyamedia.com/category/news/telugu-cinema-news/" rel="category tag">Telugu Cinema News</a></span></div><h1 class="entry-title penci-entry-title penci-title-">Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled</h1>
								<div class="entry-meta penci-entry-meta">
									<span class="entry-meta-item penci-posted-on"><i class="fa fa-clock-o"></i><time class="entry-date published updated" datetime="2020-02-29T17:07:25+05:30">February 29, 2020</time></span><span class="entry-meta-item penci-comment-count"><a class="penci_pmeta-link" href="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#respond"><i class="la la-comments"></i>0</a></span><span class="entry-meta-item penci-post-countview"><span class="entry-meta-item penci-post-countview penci_post-meta_item"><i class="fa fa-eye"></i><span class="penci-post-countview-number penci-post-countview-p79195">298</span></span></span>								</div><!-- .entry-meta -->
															</header><!-- .entry-header -->
							<div class="entry-media penci-entry-media"><div class="post-format-meta "><div class="post-image penci-standard-format"><img width="501" height="336" src="https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg" class="attachment-penci-thumb-960-auto size-penci-thumb-960-auto wp-post-image" alt="Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled" srcset="https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty.jpg 501w, https://navyamedia.com/wp-content/uploads/2020/02/Suniel-Shetty-300x201.jpg 300w" sizes="(max-width: 501px) 100vw, 501px" /></div></div>	</div><div class="penci-entry-content entry-content">
	<div class="penci-google-adsense penci_single_ad_before_content"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 1ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3970502182429648"
     data-ad-slot="5075000344"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div><p style="text-align: justify;">Manchu Vishnu starrer Mosagallu is in the last leg of shooting and the film is planned to be released in summer. Bollywood star Suniel Shetty plays a powerful cop in the film and his first look is out now.</p>
<p>Suniel Shetty in police uniform wearing turban looks dynamic here as a sincere police officer. His character name is ACP Kumar.</p>
<p>Mosagallu is based on a true story – about the biggest IT scam in history; which originated in India and shook the United States of America &nbsp;</p>
<p>The next shooting schedule will begin in the city from Monday.</p>
<p>Made under Via Mar Entertainment and AVA Entertainment, Produced by Viranica Manchu, and directed by Jeffery Gee Chin; Kajal Aggarwal and Ruhani Singh will be seen in the female lead roles.</p>
<div class="penci-google-adsense penci_single_ad_after_content"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- 1ads -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3970502182429648"
     data-ad-slot="5075000344"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><!-- .entry-content -->

							<footer class="penci-entry-footer">
								<span class="tags-links penci-tags-links"><a href="https://navyamedia.com/tag/mosagallu/" rel="tag">Mosagallu</a></span><span class="penci-social-buttons penci-social-share-footer"><span class="penci-social-share-text">Share</span><a href="#" class="penci-post-like penci_post-meta_item  single-like-button penci-social-item like" data-post_id="79195" title="Like" data-like="Like" data-unlike="Unlike"><i class="fa fa-thumbs-o-up"></i><span class="penci-share-number">0</span></a><a class="penci-social-item facebook" target="_blank" rel="noopener" title="" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F"><i class="fa fa-facebook"></i></a><a class="penci-social-item twitter" target="_blank" rel="noopener" title="" href="https://twitter.com/intent/tweet?text=Suniel%20Shetty’s%20Dynamic%20First%20look%20in%20‘Mosagallu’%20Unveiled%20-%20https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/"><i class="fa fa-twitter"></i></a><a class="penci-social-item google_plus" target="_blank" rel="noopener" title="" href="https://plus.google.com/share?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F"><i class="fa fa-google-plus"></i></a><a class="penci-social-item pinterest" target="_blank" rel="noopener" title="" href="http://pinterest.com/pin/create/button?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;media=https%3A%2F%2Fnavyamedia.com%2Fwp-content%2Fuploads%2F2020%2F02%2FSuniel-Shetty.jpg&#038;description=Suniel%20Shetty%E2%80%99s%20Dynamic%20First%20look%20in%20%E2%80%98Mosagallu%E2%80%99%20Unveiled"><i class="fa fa-pinterest"></i></a><a class="penci-social-item linkedin" target="_blank" rel="noopener" title="" href="https://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;title=Suniel%20Shetty%E2%80%99s%20Dynamic%20First%20look%20in%20%E2%80%98Mosagallu%E2%80%99%20Unveiled"><i class="fa fa-linkedin"></i></a><a class="penci-social-item tumblr" target="_blank" rel="noopener" title="" href="https://www.tumblr.com/share/link?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;name=Suniel%20Shetty%E2%80%99s%20Dynamic%20First%20look%20in%20%E2%80%98Mosagallu%E2%80%99%20Unveiled"><i class="fa fa-tumblr"></i></a><a class="penci-social-item reddit" target="_blank" rel="noopener" title="" href="https://reddit.com/submit?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;title=Suniel%20Shetty%E2%80%99s%20Dynamic%20First%20look%20in%20%E2%80%98Mosagallu%E2%80%99%20Unveiled"><i class="fa fa-reddit"></i></a><a class="penci-social-item whatsapp" rel="noopener" data-text="Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled" data-link="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/" href="#"><i class="fa fa-whatsapp"></i></a><a class="penci-social-item telegram" target="_blank" rel="noopener" title="" href="https://telegram.me/share/url?url=https%3A%2F%2Fnavyamedia.com%2Fsuniel-shettys-dynamic-first-look-in-mosagallu-unveiled%2F&#038;text=Suniel%20Shetty%E2%80%99s%20Dynamic%20First%20look%20in%20%E2%80%98Mosagallu%E2%80%99%20Unveiled"><i class="fa fa-telegram"></i></a><a class="penci-social-item email" target="_blank" rel="noopener" href="mailto:?subject=Suniel%20Shetty’s%20Dynamic%20First%20look%20in%20‘Mosagallu’%20Unveiled&#038;BODY=https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/"><i class="fa fa-envelope"></i></a></span>							</footer><!-- .entry-footer -->
						</article>
							<div class="penci-post-pagination">
					<div class="prev-post">
									<div class="prev-post-inner penci_mobj__body">
						<div class="prev-post-title">
							<span><i class="fa fa-angle-left"></i>previous post</span>
						</div>
						<div class="pagi-text">
							<h5 class="prev-title"><a href="https://navyamedia.com/vaisshnav-tejs-uppena-first-song-announcement-on-dsps-mentor-mandolin-srinivass-birth-anniversary/">Vaisshnav Tej’s Uppena First Song Announcement On DSP’s Mentor Mandolin Srinivas’s Birth Anniversary</a></h5>
						</div>
					</div>
				
			</div>
		
					<div class="next-post ">
									<div class="next-post-inner">
						<div class="prev-post-title next-post-title">
							<span>next post<i class="fa fa-angle-right"></i></span>
						</div>
						<div class="pagi-text">
							<h5 class="next-title"><a href="https://navyamedia.com/ileana-dcruz-latest-images/">Ileana D&#8217;Cruz Latest Images</a></h5>
						</div>
					</div>
							</div>
			</div>
<div class="penci-post-related"><div class="post-title-box"><h4 class="post-box-title">Related posts</h4></div><div class="post-related_content"><div  class="item-related penci-imgtype-landscape post-62545 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-telugu category-telugu-cinema-news tag-antariksham-9000-kmph tag-antariksham-9000-kmph-shoot-completed tag-telugu-cinema-news tag-varun-tej penci-post-item"><a class="related-thumb penci-image-holder penci-image_has_icon penci-lazy"  data-src="https://navyamedia.com/wp-content/uploads/2018/10/A-9000-Kmph-Shoot-Complete-480x320.jpg" href="https://navyamedia.com/antariksham-9000-kmph-shoot-completed/"></a><h4 class="entry-title"><a href="https://navyamedia.com/antariksham-9000-kmph-shoot-completed/">Antariksham 9000 KMPH’ shoot completed</a></h4><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2018-10-01T17:10:31+05:30">October 1, 2018</time></div></div><div  class="item-related penci-imgtype-landscape post-45 post type-post status-publish format-standard has-post-thumbnail hentry category-telugu-cinema-news tag-the-stolen-princess tag-telugu-cinema-news penci-post-item"><a class="related-thumb penci-image-holder penci-image_has_icon penci-lazy"  data-src="https://navyamedia.com/wp-content/uploads/2018/08/The-Stolen-Princess-480x320.jpg" href="https://navyamedia.com/the-stolen-princess-releases-on-august-24-in-english-hindi-tamil-and-telugu/"></a><h4 class="entry-title"><a href="https://navyamedia.com/the-stolen-princess-releases-on-august-24-in-english-hindi-tamil-and-telugu/">The Stolen Princess releases on August 24 in English, Hindi, Tamil and Telugu</a></h4><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2018-08-18T12:29:27+05:30">August 18, 2018</time></div></div><div  class="item-related penci-imgtype-landscape post-66603 post type-post status-publish format-standard has-post-thumbnail hentry category-telugu category-telugu-cinema-news tag-yashs-father-is-a-bigger-superstar-ss-rajamouli-at-kgfs-pre-release-event-news-updates penci-post-item"><a class="related-thumb penci-image-holder penci-image_has_icon penci-lazy"  data-src="https://navyamedia.com/wp-content/uploads/2018/12/‘Yash’s-father-is-a-bigger-superstar’-SS-Rajamouli-at-KGF’s-pre-release-event-480x320.jpg" href="https://navyamedia.com/yashs-father-is-a-bigger-superstar-ss-rajamouli-at-kgfs-pre-release-event/"></a><h4 class="entry-title"><a href="https://navyamedia.com/yashs-father-is-a-bigger-superstar-ss-rajamouli-at-kgfs-pre-release-event/">‘Yash’s father is a bigger superstar’: SS Rajamouli at KGF’s pre-release event</a></h4><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/raghavendra/">raghavendra d</a></span><time class="entry-date published updated" datetime="2018-12-10T16:46:54+05:30">December 10, 2018</time></div></div></div></div><div id="wordpress-79195-comment" class="active multi-wordpress-comment penci-tab-pane" ><div class="post-comments  post-comments-79195  no-comment-yet" id="comments">
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://navyamedia.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><span>Save my name, email, and website in this browser for the next time I comment.</span></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='79195' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	</div> <!-- end comments div -->
</div>				</div>

									</div>
			</div>
						
<aside class="widget-area widget-area-1 penci-sticky-sidebar penci-sidebar-widgets">
	<div class="theiaStickySidebar">
	<div id="penci_block_11__54936421" class="penci-block-vc penci-block_11 penci__general-meta widget penci-block-vc penci-widget-sidebar style-title-1 style-title-left penci-block-vc penci-widget penci-block_11 penci-widget__block_11 left penci-block-load_more penci-imgtype-landscape penci-link-filter-hidden penci-vc-column-1" data-current="1" data-blockUid="penci_block_11__54936421" >
	<div class="penci-block-heading">
		<h3 class="penci-block__title"><span>Trending Galleries</span></h3>					</div>
	<div id="penci_block_11__54936421block_content" class="penci-block_content">
		<div class="penci-block_content__items penci-block-items__1"><article  class="block11_first_item hentry penci-post-item"><div class="penci-post-item__inner"><a class="penci-image-holder  penci-lazy"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/Ileana-DCruz-Latest-Images-2.jpg" data-delay="" href="https://navyamedia.com/ileana-dcruz-latest-images/" title="Ileana D&#8217;Cruz Latest Images"></a><div class="penci_post_content"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/ileana-dcruz-latest-images/" title=" Ileana D&#8217;Cruz Latest Images ">Ileana D&#8217;Cruz Latest Images</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2020-02-29T17:28:31+05:30">February 29, 2020</time></div><div class="penci-pmore-link"><a href="https://navyamedia.com/ileana-dcruz-latest-images/" class="more-link button"><span>Read more</span></a></div></div></div></article><div class="block11_items"><article class="hentry penci-post-item"><div class="penci_media_object"><a class="penci-image-holder  penci-lazy penci_mobj__img"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/Mannara-4.jpg" data-delay="" href="https://navyamedia.com/mannara-chopra-latest-photo-stills/" title="Mannara Chopra Latest Photo Stills"></a><div class="penci_post_content penci_mobj__body"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/mannara-chopra-latest-photo-stills/" title=" Mannara Chopra Latest Photo Stills ">Mannara Chopra Latest Photo Stills</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2020-02-28T12:57:43+05:30">February 28, 2020</time></div></div></div></article><article class="hentry penci-post-item"><div class="penci_media_object"><a class="penci-image-holder  penci-lazy penci_mobj__img"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/RASHMIKA-Madanna-Recent-Photoshoot-7.jpg" data-delay="" href="https://navyamedia.com/rashmika-mandanna-latest-photoshoot-images/" title="Rashmika Mandanna Latest PhotoShoot Images"></a><div class="penci_post_content penci_mobj__body"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/rashmika-mandanna-latest-photoshoot-images/" title=" Rashmika Mandanna Latest PhotoShoot Images ">Rashmika Mandanna Latest PhotoShoot Images</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2020-02-26T12:28:30+05:30">February 26, 2020</time></div></div></div></article><article class="hentry penci-post-item"><div class="penci_media_object"><a class="penci-image-holder  penci-lazy penci_mobj__img"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/MAAA-Events-Fashion-Show-at-DDubs-10.jpg" data-delay="" href="https://navyamedia.com/maaa-events-fashion-show-at-bdubs-pub-photo-gallery/" title="MAAA Events Fashion Show At BDubs Pub Photo Gallery"></a><div class="penci_post_content penci_mobj__body"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/maaa-events-fashion-show-at-bdubs-pub-photo-gallery/" title=" MAAA Events Fashion Show At BDubs Pub Photo Gallery ">MAAA Events Fashion Show At BDubs Pub Photo Gallery</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published" datetime="2020-02-26T12:18:07+05:30">February 26, 2020</time><time class="updated" datetime="2020-02-26T12:18:20+05:30">February 26, 2020</time></div></div></div></article><article class="hentry penci-post-item"><div class="penci_media_object"><a class="penci-image-holder  penci-lazy penci_mobj__img"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/riaz-ahmed-art-images-16.jpg" data-delay="" href="https://navyamedia.com/riaz-ahmed-art-images/" title="Riaz Ahmed Art Images"></a><div class="penci_post_content penci_mobj__body"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/riaz-ahmed-art-images/" title=" Riaz Ahmed Art Images ">Riaz Ahmed Art Images</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published" datetime="2020-02-25T15:44:37+05:30">February 25, 2020</time><time class="updated" datetime="2020-02-25T15:46:57+05:30">February 25, 2020</time></div></div></div></article><article class="hentry penci-post-item"><div class="penci_media_object"><a class="penci-image-holder  penci-lazy penci_mobj__img"  data-src="https://navyamedia.com/wp-content/uploads/2020/02/Telugu-Actress-Shruthi-Shetty-Latest-Images.jpg" data-delay="" href="https://navyamedia.com/telugu-actress-shruthi-shetty-latest-images/" title="Telugu Actress Shruthi Shetty Latest Images"></a><div class="penci_post_content penci_mobj__body"><h3 class="penci__post-title entry-title"><a href="https://navyamedia.com/telugu-actress-shruthi-shetty-latest-images/" title=" Telugu Actress Shruthi Shetty Latest Images ">Telugu Actress Shruthi Shetty Latest Images</a></h3><div class="penci-schema-markup"><span class="author vcard"><a class="url fn n" href="https://navyamedia.com/author/admin/">admin</a></span><time class="entry-date published updated" datetime="2020-02-13T16:58:24+05:30">February 13, 2020</time></div></div></div></article></div></div><div class="penci-loader-effect penci-loading-animation-6 penci-load-thecube"><div class="penci-loading-animation penci-load-cube penci-load-c1"></div><div class="penci-loading-animation penci-load-cube penci-load-c2"></div><div class="penci-loading-animation penci-load-cube penci-load-c4"></div><div class="penci-loading-animation penci-load-cube penci-load-c3"></div></div>	</div>
	<div class="penci-pagination penci-ajax-more ">
				    <a class="penci-block-ajax-more-button button " data-mes="Sorry, No more posts" data-block_id="penci_block_11__54936421block_content" >
				     <span class="ajax-more-text">Load more posts</span><span class="ajaxdot"></span><i class="fa fa-refresh"></i>
				    </a>
				   </div></div>
<style>#penci_block_11__54936421 .penci-loading-animation-6 .penci-loading-animation:before{ background-color: #ffffff; }@media screen and (min-width: 768px ){#penci_block_11__54936421 .penci-ajax-more .penci-block-ajax-more-button{ padding-top:0; font-size:13px !important; }}#penci_block_11__54936421 .penci-subcat-filter .penci-subcat-item a,#penci_block_11__54936421 .penci-subcat-list .flexMenu-viewMore > a{ font-family:"Mukta Vaani";font-weight:400; }#penci_block_11__54936421 .penci-pmore-link .more-link{ font-family:"Mukta Vaani";font-weight:500; }#penci_block_11__54936421 .penci-pmore-link .more-link{ color:#ffffff; }</style><script>if( typeof(penciBlock) === "undefined" ) {function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}}var penciBlocksArray = penciBlocksArray || [];var PENCILOCALCACHE = PENCILOCALCACHE || {};var penci_block_11__54936421 = new penciBlock();penci_block_11__54936421.blockID="penci_block_11__54936421";penci_block_11__54936421.atts_json = '{"build_query":"post_type:post|size:6|categories:9","add_title_icon":"","title_i_align":"left","title_icon":"","hide_thumb":"","image_type":"landscape","block_title_meta_settings":"","block_title_align":"left","block_title_off_uppercase":"","block_title_wborder_left_right":"5px","block_title_wborder":"3px","post_title_trimword_settings":"","post_big_title_length":"20","post_standard_title_length":"12","hide_comment":"1","hide_post_date":"1","hide_icon_post_format":"1","show_readmore":"1","dis_bg_block":"","enable_stiky_post":"1","style_pag":"load_more","limit_loadmore":"3","readmore_css":"","pagination_css":"","loadmore_css":"","disable_bg_load_more":"","custom_markup_1":"","ajax_filter_type":"","ajax_filter_selected":"","ajax_filter_number_item":"5","infeed_ads__order":"","block_id":"penci-widget__block_11-2","penci_show_desk":"Yes","penci_show_tablet":"Yes","penci_show_mobile":"Yes","paged":1,"unique_id":"penci_block_11__54936421","shortcode_id":"block_11","column_number":1,"category_ids":""}';penci_block_11__54936421.content="";penciBlocksArray.push(penci_block_11__54936421);</script><div id="text-2" class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- 1ads --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3970502182429648"
     data-ad-slot="5075000344"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div>		<div id="recent-posts-2" class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_recent_entries">		<div class="penci-block-heading"><h4 class="widget-title penci-block__title"><span>Recent Posts</span></h4></div>		<ul>
											<li>
					<a href="https://navyamedia.com/ileana-dcruz-latest-images/">Ileana D&#8217;Cruz Latest Images</a>
									</li>
											<li>
					<a href="https://navyamedia.com/suniel-shettys-dynamic-first-look-in-mosagallu-unveiled/">Suniel Shetty’s Dynamic First look in ‘Mosagallu’ Unveiled</a>
									</li>
											<li>
					<a href="https://navyamedia.com/vaisshnav-tejs-uppena-first-song-announcement-on-dsps-mentor-mandolin-srinivass-birth-anniversary/">Vaisshnav Tej’s Uppena First Song Announcement On DSP’s Mentor Mandolin Srinivas’s Birth Anniversary</a>
									</li>
											<li>
					<a href="https://navyamedia.com/rd10-a-teaser-of-rana-daggubatis-10-years-film-journey-is-released/">RD10, A Teaser Of Rana Daggubati’s 10 Years Film Journey Is Released</a>
									</li>
											<li>
					<a href="https://navyamedia.com/sree-vishnus-film-with-people-media-factory-and-abhishek-agarwal-arts-titled-raja-raja-chora/">*Sree Vishnu’s film with People Media Factory and Abhishek Agarwal Arts titled “Raja Raja Chora”*</a>
									</li>
					</ul>
		</div><div id="text-3" class="widget  penci-block-vc penci-widget-sidebar style-title-1 style-title-left widget_text">			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br />
<!-- 1ads --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3970502182429648"
     data-ad-slot="5075000344"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins><br />
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div>	</div>
</aside><!-- #secondary -->
		</div>

	</div>
		</main><!-- #main -->
	</div><!-- #primary -->
	</div><!-- #content -->
	<footer id="colophon" class="site-footer" itemscope itemtype="http://schema.org/WPFooter">
		<meta itemprop="name" content="Webpage footer for Navyamedia"/>
		<meta itemprop="description" content="AP,Telangana Political News | Telugu Cinema News"/>
		<meta itemprop="keywords" content="Data Protection, Copyright Data"/>
		<meta itemprop="copyrightYear" content="2020"/>
		<meta itemprop="copyrightHolder" content="Navyamedia"/>
										<div class="footer__copyright_menu">
			<div class="footer__sidebars-inner penci-container-fluid penci_bottom-sub penci_has_copyright">
			<div class="site-info">
				<p style="text-align:left"><font color="white">@2018 - navyamedia.com. All Right Reserved  by NavyaMedia </font> <span style="float:right"> <a href="https://navyamedia.com/disclaimer/"> <font color="white"> Disclaimer </font></a>  ||  <a href="https://navyamedia.com/privacy-policy/"> <font color="white">Privacy Policy</font></a>   ||   <a href="https://navyamedia.com/advertise-with-us/"> <font color="white">Advertise With us</font></a>   ||   <a href="https://navyamedia.com/contact-us/"> <font color="white"> Contact us</font>  </a></span></p>			</div><!-- .site-info -->
					</div>
	</div>	</footer><!-- #colophon -->
</div><!-- #page -->

<aside class="mobile-sidebar ">

			<div id="sidebar-nav-logo">
								<a href="https://navyamedia.com/" class="custom-logo-link" rel="home"><img width="444" height="114" src="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download.png" class="custom-logo" alt="Navyamedia" srcset="https://navyamedia.com/wp-content/uploads/2019/04/cropped-download.png 444w, https://navyamedia.com/wp-content/uploads/2019/04/cropped-download-300x77.png 300w" sizes="(max-width: 444px) 100vw, 444px" /></a>						</div>
				<div class="header-social sidebar-nav-social">
			<div class="inner-header-social">
				<a class="social-media-item socail_media__facebook" target="_blank" href="https://www.facebook.com/navyamedia/" title="Facebook" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-facebook"></i><span class="social_title screen-reader-text">Facebook</span></span></a><a class="social-media-item socail_media__twitter" target="_blank" href="https://twitter.com/Navyamedia" title="Twitter" rel="noopener"><span class="socail-media-item__content"><i class="fa fa-twitter"></i><span class="social_title screen-reader-text">Twitter</span></span></a>			</div>
		</div>
				<nav class="mobile-navigation" itemscope itemtype="http://schema.org/SiteNavigationElement">
			<ul id="primary-menu-mobile" class="primary-menu-mobile"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-88"><a href="https://navyamedia.com/home/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-84"><a href="https://navyamedia.com/category/news/">news</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-85"><a href="https://navyamedia.com/category/news/politics/">Political News</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59498"><a href="https://navyamedia.com/category/andhra-pradesh-political-news/">Andhra Pradesh</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59504"><a href="https://navyamedia.com/category/telangana/">Telangana</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59502"><a href="https://navyamedia.com/category/national/">National</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59501"><a href="https://navyamedia.com/category/international/">International</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-86"><a href="https://navyamedia.com/category/news/telugu-cinema-news/">Cinema News</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59507"><a href="https://navyamedia.com/category/telugu/">Telugu</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59506"><a href="https://navyamedia.com/category/tamil/">Tamil</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-59505"><a href="https://navyamedia.com/category/hindi/">Hindi</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59096"><a href="https://navyamedia.com/category/crime/">Crime News</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-59497"><a href="#">Galleries</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78"><a href="https://navyamedia.com/category/artistes-gallery/">Artist Gallaery</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-83"><a href="https://navyamedia.com/category/movie-gallery/">Movie Gallery</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79"><a href="https://navyamedia.com/category/business-news/">Business News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59098"><a href="https://navyamedia.com/category/education-news/">Educational News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59500"><a href="https://navyamedia.com/category/health-news/">Health News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59503"><a href="https://navyamedia.com/category/technology/">Technology</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-59508"><a href="https://navyamedia.com/category/sports/">Sports News</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-59147"><a href="http://telugu.navyamedia.com/">Telugu Website</a></li>
</ul>		</nav>
	</aside>
<a id="close-sidebar-nav" class="header-1"><i class="fa fa-close"></i></a>
	<a href="#" id="scroll-to-top"><i class="fa fa-angle-up"></i></a>
<!-- ngg_resource_manager_marker --><script type='text/javascript' src='https://navyamedia.com/wp-content/plugins/penci-pennews-recipe/js/jquery.rateyo.min.js?ver=2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/navyamedia.com\/wp-admin\/admin-ajax.php","nonce":"61f47b5b7b"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navyamedia.com/wp-content/plugins/penci-pennews-recipe/js/rating_recipe.js?ver=2.3.2'></script>
<script type='text/javascript' src='https://navyamedia.com/wp-content/plugins/penci-pennews-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/navyamedia.com\/wp-admin\/admin-ajax.php","nonce":"61f47b5b7b"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navyamedia.com/wp-content/plugins/penci-pennews-review/js/rating_review.js?ver=3.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCILOCALIZE = {"ajaxUrl":"https:\/\/navyamedia.com\/wp-admin\/admin-ajax.php","nonce":"61f47b5b7b","errorMsg":"Something wrong happened. Please try again.","login":"Email Address","password":"Password","errorPass":"<p class=\"message message-error\">Password does not match the confirm password<\/p>","prevNumber":"1","minlengthSearch":"0","linkTitle":"View More","linkTextAll":"Menu","linkText":"More"};
/* ]]> */
</script>
<script type='text/javascript' src='https://navyamedia.com/wp-content/themes/pennews/js/script.min.js?ver=6.5.1'></script>
<script type='text/javascript' src='https://navyamedia.com/wp-includes/js/comment-reply.min.js?ver=5.2.5'></script>
<script type='text/javascript' src='https://navyamedia.com/wp-includes/js/wp-embed.min.js?ver=5.2.5'></script>
			<script type="text/javascript">
				jQuery(document).ready(function() {
					jQuery('.penci-social-item.whatsapp').on("click", function(e) {
						if(/Android|webOS|iPhone|iPad|iPod|BlackBerry|IEMobile|Opera Mini/i.test(navigator.userAgent) ) {
							var article = jQuery(this).attr("data-text");
							var weburl = jQuery(this).attr("data-link");
							var whats_app_message = encodeURIComponent(article)+" - "+encodeURIComponent(weburl);
							var whatsapp_url = "whatsapp://send?text="+whats_app_message;
							window.location.href= whatsapp_url;
						}else{
							alert('Sharing on whatsapp will does not work on PC.');
						}
					});
				});
			</script>
			<!-- Default Statcounter code for
http://aftercareservicecontracts
http://aftercareservicecontracts.com -->
<script type="text/javascript">
var sc_project=11008727; 
var sc_invisible=1; 
var sc_security="2f7004dc"; 
</script>
<script type="text/javascript"
src="https://www.statcounter.com/counter/counter.js"
async></script>
<noscript><div class="statcounter"><a title="Web Analytics
Made Easy - StatCounter" href="https://statcounter.com/"
target="_blank"><img class="statcounter"
src="https://c.statcounter.com/11008727/0/2f7004dc/1/"
alt="Web Analytics Made Easy -
StatCounter"></a></div></noscript>
<!-- End of Statcounter Code -->
<center><a href="https://bali-gram.com">Real emotions of real people from Bali</a></center>
</body>
</html>
